<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.cieonline.co.uk/xmlrpc.php" />
<title>Flex Power Modules signs global partnership agreement with Digi-Key &#8211; CIE</title>
<meta property="og:title" content="Flex Power Modules signs global partnership agreement with Digi-Key - CIE"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Flex Power Modules has signed a partnership agreement with Digi-Key Electronics, a global electronic"/>
<meta property="og:url" content="https://www.cieonline.co.uk/flex-power-modules-signs-global-partnership-agreement-with-digi-key/"/>
<meta property="og:site_name" content="CIE"/>
<meta property="og:image" content="https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee-631x330.jpg" />
<link rel='dns-prefetch' href='//cieonline.co.uk' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CIE &raquo; Feed" href="https://www.cieonline.co.uk/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.cieonline.co.uk\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//cieonline.co.uk/wp-content/plugins/all-in-one-event-calendar/public/themes-ai1ec/vortex/css/ai1ec_parsed_css.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.cieonline.co.uk/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-notice-front-css'  href='https://www.cieonline.co.uk/wp-content/plugins/cookie-notice/css/front.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='spu-public-css-css'  href='https://www.cieonline.co.uk/wp-content/plugins/popups/public/assets/css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://www.cieonline.co.uk/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://www.cieonline.co.uk/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cnArgs = {"ajaxurl":"https:\/\/www.cieonline.co.uk\/wp-admin\/admin-ajax.php","hideEffect":"fade","onScroll":"no","onScrollOffset":"100","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/plugins/cookie-notice/js/front.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aamLocal = {"nonce":"81dd18f4bc","ajaxurl":"https:\/\/www.cieonline.co.uk\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.cieonline.co.uk/wp-content/plugins/advanced-access-manager/media/js/aam-login.js'></script>
<link rel='https://api.w.org/' href='https://www.cieonline.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.cieonline.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cieonline.co.uk/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='IBASE Announce SMARC 2.0 CPU Module with NXP i.MX 8M Mini Processor' href='https://www.cieonline.co.uk/ibase-announce-smarc-2-0-cpu-module-with-nxp-i-mx-8m-mini-processor/' />
<link rel='next' title='EMVCo certifies Trustonic to secure mobile payments apps' href='https://www.cieonline.co.uk/emvco-certifies-trustonic-to-secure-mobile-payments-apps/' />
<meta name="generator" content="WordPress 5.2.1" />
<link rel="canonical" href="https://www.cieonline.co.uk/flex-power-modules-signs-global-partnership-agreement-with-digi-key/" />
<link rel='shortlink' href='https://www.cieonline.co.uk/?p=50398' />
<link rel="alternate" type="application/json+oembed" href="https://www.cieonline.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cieonline.co.uk%2Fflex-power-modules-signs-global-partnership-agreement-with-digi-key%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cieonline.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cieonline.co.uk%2Fflex-power-modules-signs-global-partnership-agreement-with-digi-key%2F&#038;format=xml" />
<link rel="shortcut icon" href="https://cieonline.co.uk/wp-content/uploads/2017/04/CiE-Icon-32.ico" /><link rel="shortcut icon" href="https://cieonline.co.uk/wp-content/uploads/CiE-Icon-32.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://www.cieonline.co.uk/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://www.cieonline.co.uk/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.cieonline.co.uk/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.cieonline.co.uk/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://www.cieonline.co.uk/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />



<style type="text/css" media="screen">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</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.cieonline.co.uk\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.cieonline.co.uk\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<!-- Tracking code easily added by NK Google Analytics -->
<script type="text/javascript"> 
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ 
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), 
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) 
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); 
ga('create', 'UA-33932740-1', 'auto'); 
ga('send', 'pageview'); 
</script> 
</head>
<body id="top" class="post-template-default single single-post postid-50398 single-format-standard cookies-not-set">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://www.cieonline.co.uk/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://www.cieonline.co.uk/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/cie_magazine" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed-all">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

			
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-1030" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1030"><a href="https://www.cieonline.co.uk/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-40470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40470"><a href="https://www.cieonline.co.uk/cookies/">Cookies</a></li>
	<li id="menu-item-40472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40472"><a href="https://www.cieonline.co.uk/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-40471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40471"><a href="https://www.cieonline.co.uk/terms-conditions/">Terms &#038; Conditions</a></li>
</ul>
</li>
<li id="menu-item-1031" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1031"><a href="https://www.cieonline.co.uk/registration/">Registration</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1033"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEMP2020/html/index.html?page=1">Media Info</a></li>
<li id="menu-item-40263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40263"><a href="https://www.cieonline.co.uk/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-31333" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31333"><a href="https://www.cieonline.co.uk/contact-us/">Contact Us</a></li>
<li id="menu-item-18570" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18570"><a href="/wp-admin">Client Login</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://www.cieonline.co.uk/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://www.cieonline.co.uk/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/cie_magazine" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo" style=" margin-bottom:10px;">
			<h2>								<a title="CIE" href="https://www.cieonline.co.uk/">
					<img src="https://cieonline.co.uk/wp-content/uploads/2017/04/cie-logo.png" alt="CIE" width="148" height="110" /><strong>CIE Components in Electronics</strong>
				</a>
			</h2>			</div><!-- .logo /-->
<script type="text/javascript">
jQuery(document).ready(function($) {
	var retina = window.devicePixelRatio > 1 ? true : false;
	if(retina) {
       	jQuery('#theme-header .logo img').attr('src',		'https://cieonline.co.uk/wp-content/uploads/2017/04/cie-logox2.png');
       	jQuery('#theme-header .logo img').attr('width',		'148');
       	jQuery('#theme-header .logo img').attr('height',	'110');
	}
});
</script>
			<div class="e3lan e3lan-top">			<ins data-revive-zoneid="418" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-978"><a href="https://www.cieonline.co.uk/">HomePage</a></li>
<li id="menu-item-977" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-977 mega-menu mega-recent-featured "><a href="https://www.cieonline.co.uk/category/news/"><i class="fa fa-newspaper-o"></i>News</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-1049" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1049"><a href="https://www.cieonline.co.uk/category/news/"><i class="fa fa-area-chart"></i>Latest Developments</a></li>
	<li id="menu-item-28342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28342"><a href="https://www.cieonline.co.uk/category/news/interviews-comments/"><i class="fa fa-comments-o"></i>Interviews &#038; Comments</a></li>
	<li id="menu-item-1048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1048"><a href="https://www.cieonline.co.uk/category/news/profiles/"><i class="fa fa-child"></i>Profiles</a></li>
	<li id="menu-item-29688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29688"><a href="https://www.cieonline.co.uk/calendar-2/"><i class="fa fa-calendar-check-o"></i>Calendar</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/" title="Infovista launches TEMS for Industry 4.0 for connected applications"><img src="https://www.cieonline.co.uk/wp-content/uploads/image002-16.jpg" width="660" height="330" alt="Infovista launches TEMS for Industry 4.0 for connected applications" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/" title="Infovista launches TEMS for Industry 4.0 for connected applications">Infovista launches TEMS for Industry 4.0 for connected applications</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>20 mins ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/" title="Advances in EV Charging Infrastructure"><img src="https://www.cieonline.co.uk/wp-content/uploads/shutterstock_754400164-110x75.jpg" width="110" height="75" alt="Advances in EV Charging Infrastructure" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/" title="Advances in EV Charging Infrastructure">Advances in EV Charging Infrastructure</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>26 mins ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/further-regulation-required-around-iot-device-security/" title="Further regulation required around IoT device security"><img src="https://www.cieonline.co.uk/wp-content/uploads/11817-IoTSF-Vulnerability-Disclosure-110x75.jpg" width="110" height="75" alt="Further regulation required around IoT device security" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/further-regulation-required-around-iot-device-security/" title="Further regulation required around IoT device security">Further regulation required around IoT device security</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>3 hours ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/" title="Arrow Electronics adds Xunzel renewable energy portfolio"><img src="https://www.cieonline.co.uk/wp-content/uploads/ARP097_Solarlife-Pro-Xunzel_LRES-110x75.jpg" width="110" height="75" alt="Arrow Electronics adds Xunzel renewable energy portfolio" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/" title="Arrow Electronics adds Xunzel renewable energy portfolio">Arrow Electronics adds Xunzel renewable energy portfolio</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>3 hours ago</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-1045" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1045 mega-menu mega-recent-featured "><a href="https://www.cieonline.co.uk/category/features/"><i class="fa fa-cubes"></i>Features</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-28343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28343"><a href="https://www.cieonline.co.uk/category/features/aerospace-military-defence/"><i class="fa fa-fighter-jet"></i>Aerospace, Military &#038; Defence</a></li>
	<li id="menu-item-28344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28344"><a href="https://www.cieonline.co.uk/category/features/automotive/"><i class="fa fa-car"></i>Automotive</a></li>
	<li id="menu-item-1036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1036"><a href="https://www.cieonline.co.uk/category/features/displays/"><i class="fa fa-television"></i>Displays</a></li>
	<li id="menu-item-1037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1037"><a href="https://www.cieonline.co.uk/category/features/distribution/"><i class="fa fa-archive"></i>Distribution</a></li>
	<li id="menu-item-1039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1039"><a href="https://www.cieonline.co.uk/category/features/embedded/"><i class="fa fa-compress"></i>Embedded</a></li>
	<li id="menu-item-28345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28345"><a href="https://www.cieonline.co.uk/category/features/enclosures/"><i class="fa fa-codepen"></i>Enclosures</a></li>
	<li id="menu-item-1040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1040"><a href="https://www.cieonline.co.uk/category/features/ics-semiconductors/"><i class="fa fa-connectdevelop"></i>ICs &#038; Semiconductors</a></li>
	<li id="menu-item-28346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28346"><a href="https://www.cieonline.co.uk/category/features/industrial/"><i class="fa fa-industry"></i>Industrial</a></li>
	<li id="menu-item-1041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1041"><a href="https://www.cieonline.co.uk/category/features/interconnection/"><i class="fa fa-arrows"></i>Interconnection</a></li>
	<li id="menu-item-28347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28347"><a href="https://www.cieonline.co.uk/category/features/internet-of-things/"><i class="fa fa-globe"></i>Internet of Things</a></li>
	<li id="menu-item-28348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28348"><a href="https://www.cieonline.co.uk/category/features/led-technology/"><i class="fa fa-lightbulb-o"></i>LED Technology</a></li>
	<li id="menu-item-29647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29647"><a href="https://www.cieonline.co.uk/category/features/optoelectronics/"><i class="fa fa-eye"></i>Optoelectronics</a></li>
	<li id="menu-item-1042" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1042"><a href="https://www.cieonline.co.uk/category/features/power/"><i class="fa fa-bolt"></i>Power</a></li>
	<li id="menu-item-28349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28349"><a href="https://www.cieonline.co.uk/category/features/test-measurement/"><i class="fa fa-area-chart"></i>Test &#038; Measurement</a></li>
	<li id="menu-item-29427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29427"><a href="https://www.cieonline.co.uk/category/features/thermal-management/"><i class="fa fa-fire"></i>Thermal Management</a></li>
	<li id="menu-item-1044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1044"><a href="https://www.cieonline.co.uk/category/features/wireless-communications/"><i class="fa fa-wifi"></i>Wireless &#038; Communications</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/" title="Infovista launches TEMS for Industry 4.0 for connected applications"><img src="https://www.cieonline.co.uk/wp-content/uploads/image002-16.jpg" width="660" height="330" alt="Infovista launches TEMS for Industry 4.0 for connected applications" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/" title="Infovista launches TEMS for Industry 4.0 for connected applications">Infovista launches TEMS for Industry 4.0 for connected applications</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>20 mins ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/" title="Advances in EV Charging Infrastructure"><img src="https://www.cieonline.co.uk/wp-content/uploads/shutterstock_754400164-110x75.jpg" width="110" height="75" alt="Advances in EV Charging Infrastructure" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/" title="Advances in EV Charging Infrastructure">Advances in EV Charging Infrastructure</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>26 mins ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/" title="Arrow Electronics adds Xunzel renewable energy portfolio"><img src="https://www.cieonline.co.uk/wp-content/uploads/ARP097_Solarlife-Pro-Xunzel_LRES-110x75.jpg" width="110" height="75" alt="Arrow Electronics adds Xunzel renewable energy portfolio" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/" title="Arrow Electronics adds Xunzel renewable energy portfolio">Arrow Electronics adds Xunzel renewable energy portfolio</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>3 hours ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="https://www.cieonline.co.uk/shetland-space-centre-receives-2-million-boost-to-initiate-satellite-launch-programme-2/" title="Shetland Space Centre receives £2 million boost to initiate satellite launch programme"><img src="https://www.cieonline.co.uk/wp-content/uploads/y1Hhg29g_400x400-110x75.jpg" width="110" height="75" alt="Shetland Space Centre receives £2 million boost to initiate satellite launch programme" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://www.cieonline.co.uk/shetland-space-centre-receives-2-million-boost-to-initiate-satellite-launch-programme-2/" title="Shetland Space Centre receives £2 million boost to initiate satellite launch programme">Shetland Space Centre receives £2 million boost to initiate satellite launch programme</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>8 hours ago</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-1050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1050"><a href="http://www.ciedirectory.co.uk"><i class="fa fa-search-plus"></i>Distributor Directory</a></li>
<li id="menu-item-17609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17609"><a><i class="fa fa-file-image-o"></i>Digital Issues</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-49948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49948"><a>2020</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-50310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50310"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEFeb2020/html/index.html?page=1">February</a></li>
		<li id="menu-item-49949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49949"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEDecJan2020/html/index.html?page=1">December/January</a></li>
	</ul>
</li>
	<li id="menu-item-47491" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47491"><a href="http://google.com">2019</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-49464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49464"><a href="https://content.yudu.com/web/69r/0A18qm2/CIENov2019/html/index.html?page=1">November</a></li>
		<li id="menu-item-49211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49211"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEOct2019/html/index.html?page=1">October</a></li>
		<li id="menu-item-48895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48895"><a href="https://content.yudu.com/web/69r/0A18qm2/CIESept2019/html/index.html?page=1">September</a></li>
		<li id="menu-item-48569" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48569"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEJulAug2019/html/index.html?page=1">July/August</a></li>
		<li id="menu-item-48128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48128"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEJune2019/index.html">June</a></li>
		<li id="menu-item-47996" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47996"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEMAY2019/html/index.html">May</a></li>
		<li id="menu-item-47798" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47798"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEAPR2019/html/index.html?origin=reader">April</a></li>
		<li id="menu-item-47720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47720"><a href="https://content.yudu.com/web/69r/0A18qm2/ciemar2019/html/index.html">March</a></li>
		<li id="menu-item-47608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47608"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEFeb2019/index.html">February</a></li>
		<li id="menu-item-47492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47492"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEDecJan2019/html/index.html">December/January</a></li>
	</ul>
</li>
	<li id="menu-item-33363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33363"><a>2018</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-46276" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46276"><a href="https://content.yudu.com/web/69r/0A18qm2/CIENov2018/html/index.html">November</a></li>
		<li id="menu-item-45233" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-45233"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEOct2018/html/index.html">October</a></li>
		<li id="menu-item-44112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44112"><a href="https://content.yudu.com/web/69r/0A18qm2/CIESept2018/html/index.html">September</a></li>
		<li id="menu-item-43206" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-43206"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEJulAug2018/index.html">July/August</a></li>
		<li id="menu-item-41702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41702"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEJune2018/html/index.html">June</a></li>
		<li id="menu-item-40535" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40535"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEMay2018/index.html">May</a></li>
		<li id="menu-item-39722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39722"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEApr2018/index.html">April</a></li>
		<li id="menu-item-39050" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39050"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEMarch2018/index.html">March</a></li>
		<li id="menu-item-34829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-34829"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEFeb2018/index.html">February</a></li>
		<li id="menu-item-33364" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33364"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEDecJan2018/html/index.html">December / January</a></li>
	</ul>
</li>
	<li id="menu-item-17610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17610"><a>2017</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-31731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31731"><a href="https://content.yudu.com/web/69r/0A18qm2/CIENov2017/index.html">November</a></li>
		<li id="menu-item-31079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31079"><a href="https://content.yudu.com/web/69r/0A18qm2/CIEOct2017/index.html">October</a></li>
		<li id="menu-item-29892" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29892"><a href="https://content.yudu.com/web/69r/0A18qm2/CIESept2017/index.html">September</a></li>
		<li id="menu-item-17611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17611"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEJulAug2017/index.html">July / August</a></li>
		<li id="menu-item-17612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17612"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEJune2017/html/index.html">June</a></li>
		<li id="menu-item-17613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17613"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEMay2017/index.html">May</a></li>
		<li id="menu-item-17614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17614"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEApr2017/index.html">April</a></li>
		<li id="menu-item-17615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17615"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEMar2017/index.html">March</a></li>
		<li id="menu-item-17616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17616"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEFeb2017/index.html">February</a></li>
		<li id="menu-item-17618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17618"><a href="http://content.yudu.com/web/69r/0A18qm2/CiEDecJan201617/index.html">December / January</a></li>
	</ul>
</li>
	<li id="menu-item-17617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17617"><a>2016</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-17619" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17619"><a href="http://content.yudu.com/web/69r/0A18qm2/CIENov2016/html/index.html">November</a></li>
		<li id="menu-item-17620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17620"><a href="http://content.yudu.com/web/69r/0A18qm2/CiEOct2016/index.html">October</a></li>
		<li id="menu-item-17621" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17621"><a href="http://content.yudu.com/web/69r/0A18qm2/CiESept2016/index.html">September</a></li>
		<li id="menu-item-17622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17622"><a href="http://content.yudu.com/web/69r/0A18qm2/CiEJulAug2016/index.html">July / August</a></li>
		<li id="menu-item-17623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17623"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEJune2016/index.html">June</a></li>
		<li id="menu-item-17624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17624"><a href="http://content.yudu.com/web/69r/0A18qm2/CIEMay2016/index.html">May</a></li>
		<li id="menu-item-17625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17625"><a href="http://content.yudu.com/A3zdue/CiEApr2016">April</a></li>
		<li id="menu-item-17626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17626"><a href="http://content.yudu.com/A3z3kx/CiEMar2016">March</a></li>
		<li id="menu-item-17627" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17627"><a href="http://content.yudu.com/A3yry7/CiEFeb2016">February</a></li>
		<li id="menu-item-17628" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17628"><a href="http://content.yudu.com/A3yhau/CIEDecJan2016">December / January</a></li>
	</ul>
</li>
</ul>
</li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	<div class="e3lan e3lan-below_header">			<ins data-revive-zoneid="480" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>				</div>
	<div id="main-content" class="container">
	
	
	
	
	
	<div class="content">

		
		
		
		<div class="revive-cat"><ins data-revive-zoneid="470" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins><script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script></div>		
				
		<article class="post-listing post-50398 post type-post status-publish format-standard has-post-thumbnail  category-news category-power" id="the-post">
			
			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Flex Power Modules signs global partnership agreement with Digi-Key</span></h1>

						
<p class="post-meta">
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="https://www.cieonline.co.uk/category/news/" rel="category tag">News</a>, <a href="https://www.cieonline.co.uk/category/features/power/" rel="category tag">Power</a></span>
	
<span class="post-views"><i class="fa fa-eye"></i>125 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<p class="p1">Flex Power Modules has signed a partnership agreement with Digi-Key Electronics, a global electronics components distributor, to open a new sales channel expanding its global footprint and accelerating customer order fulfilment.</p>
<p class="p1"><img class="alignleft size-medium wp-image-50400" src="https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee-300x163.jpg" alt="" width="300" height="163" srcset="https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee-300x163.jpg 300w, https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee-150x81.jpg 150w, https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee.jpg 631w" sizes="(max-width: 300px) 100vw, 300px" />All Flex Power Modules products will be listed on Digi-Key’s website and available for purchase, with many held in stock for immediate same-day dispatch.</p>
<p class="p1">“This agreement offers a new global sales channel for our customers to buy Flex Power Modules products, and, by improving the speed of delivery, it demonstrates our commitment to engineers worldwide,” said Marcus Hansson, VP &amp; General Manager, Flex Power Modules. “Digi-Key delivers excellent service to its customers, which is one of the core business values held by Flex. We look forward to nurturing a distribution partnership that will enhance our services for our customers.”</p>
<p class="p1">“Engineers demand high efficiency and high power density in a small size, while still being able to check the box on value for the money. Flex Power Modules’ market-leading products deliver just that to customers,” said David Stein, vice president of global supplier management at Digi-Key Electronics. “Flex Power Modules is a leading DC-DC power module vendor, and its products are a valuable addition to our line card in all global markets.”</p>
<p class="p1">Digi-Key is the fifth-largest electronics component distributor in the world. At any given time, over 1.8 million products are in stock and ready to be shipped from Digi-Key’s headquarters in Thief River Falls, Minn., USA. That means there are no lead times for in-stock products which enables the company to ship 99% of all orders the same day they are placed. Digi-Key ships an average of around 18,000 orders per day.</p>
					
									</div><!-- .entry /-->


				<div class="share-post">
	<span class="share-text">Share</span>
	
		<ul class="flat-social">	
			<li><a href="http://www.facebook.com/sharer.php?u=https://www.cieonline.co.uk/?p=50398" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
		
			<li><a href="https://twitter.com/intent/tweet?text=Flex+Power+Modules+signs+global+partnership+agreement+with+Digi-Key&url=https://www.cieonline.co.uk/?p=50398" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
				<li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https://www.cieonline.co.uk/?p=50398&amp;name=Flex+Power+Modules+signs+global+partnership+agreement+with+Digi-Key" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li>
				<li><a href="http://www.stumbleupon.com/submit?url=https://www.cieonline.co.uk/?p=50398&title=Flex+Power+Modules+signs+global+partnership+agreement+with+Digi-Key" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li>
				<li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.cieonline.co.uk/?p=50398&title=Flex+Power+Modules+signs+global+partnership+agreement+with+Digi-Key" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li>
				<li><a href="http://pinterest.com/pin/create/button/?url=https://www.cieonline.co.uk/?p=50398&amp;description=Flex+Power+Modules+signs+global+partnership+agreement+with+Digi-Key&amp;media=https://www.cieonline.co.uk/wp-content/uploads/d6f42f3ab235ffb539856471cee141ee-631x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->				<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2020-03-02T14:05:51+00:00","datePublished":"2020-03-02T14:05:51+00:00","dateModified":"2020-03-02T14:05:51+00:00","headline":"Flex Power Modules signs global partnership agreement with Digi-Key","name":"Flex Power Modules signs global partnership agreement with Digi-Key","keywords":[],"url":"https:\/\/www.cieonline.co.uk\/flex-power-modules-signs-global-partnership-agreement-with-digi-key\/","description":"Flex Power Modules has signed a partnership agreement with Digi-Key Electronics, a global electronics components distributor, to open a new sales channel expanding its global footprint and acceleratin","copyrightYear":"2020","publisher":{"@id":"#Publisher","@type":"Organization","name":"CIE","logo":{"@type":"ImageObject","url":"https:\/\/cieonline.co.uk\/wp-content\/uploads\/2017\/04\/cie-logox2.png"},"sameAs":["https:\/\/www.twitter.com\/cie_magazine"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.cieonline.co.uk\/flex-power-modules-signs-global-partnership-agreement-with-digi-key\/"},"author":{"@type":"Person","name":"CIE Editor","url":"https:\/\/www.cieonline.co.uk\/author\/cieeditor2\/"},"articleSection":"News,Power","articleBody":"Flex Power Modules has signed a partnership agreement with Digi-Key Electronics, a global electronics components distributor, to open a new sales channel expanding its global footprint and accelerating customer order fulfilment.\r\nAll Flex Power Modules products will be listed on Digi-Key\u2019s website and available for purchase, with many held in stock for immediate same-day dispatch.\r\n\u201cThis agreement offers a new global sales channel for our customers to buy Flex Power Modules products, and, by improving the speed of delivery, it demonstrates our commitment to engineers worldwide,\u201d said Marcus Hansson, VP &amp; General Manager, Flex Power Modules. \u201cDigi-Key delivers excellent service to its customers, which is one of the core business values held by Flex. We look forward to nurturing a distribution partnership that will enhance our services for our customers.\u201d\r\n\u201cEngineers demand high efficiency and high power density in a small size, while still being able to check the box on value for the money. Flex Power Modules\u2019 market-leading products deliver just that to customers,\u201d said David Stein, vice president of global supplier management at Digi-Key Electronics. \u201cFlex Power Modules is a leading DC-DC power module vendor, and its products are a valuable addition to our line card in all global markets.\u201d\r\nDigi-Key is the fifth-largest electronics component distributor in the world. At any given time, over 1.8 million products are in stock and ready to be shipped from Digi-Key\u2019s headquarters in Thief River Falls, Minn., USA. That means there are no lead times for in-stock products which enables the company to ship 99% of all orders the same day they are placed. Digi-Key ships an average of around 18,000 orders per day.","image":{"@type":"ImageObject","url":"https:\/\/www.cieonline.co.uk\/wp-content\/uploads\/d6f42f3ab235ffb539856471cee141ee.jpg","width":696,"height":342}}</script>
		</article><!-- .post-listing -->
		

		
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/">
						<img width="310" height="82" src="https://www.cieonline.co.uk/wp-content/uploads/image002-16-310x82.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://www.cieonline.co.uk/infovista-launches-tems-for-industry-4-0-for-connected-applications/" rel="bookmark">Infovista launches TEMS for Industry 4.0 for connected applications</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>20 mins ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/">
						<img width="310" height="165" src="https://www.cieonline.co.uk/wp-content/uploads/shutterstock_754400164-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://www.cieonline.co.uk/advances-in-ev-charging-infrastructure/" rel="bookmark">Advances in EV Charging Infrastructure</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>26 mins ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://www.cieonline.co.uk/further-regulation-required-around-iot-device-security/">
						<img width="310" height="165" src="https://www.cieonline.co.uk/wp-content/uploads/11817-IoTSF-Vulnerability-Disclosure-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://www.cieonline.co.uk/further-regulation-required-around-iot-device-security/" rel="bookmark">Further regulation required around IoT device security</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>3 hours ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/">
					<img width="310" height="165" src="https://www.cieonline.co.uk/wp-content/uploads/ARP097_Solarlife-Pro-Xunzel_LRES-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://www.cieonline.co.uk/arrow-electronics-adds-xunzel-renewable-energy-portfolio/" rel="bookmark">Arrow Electronics adds Xunzel renewable energy portfolio</a></h2>
			<p>Arrow Electronics has entered into an agreement with Xunzel to supply a range of products &hellip;</p>
		</div>
			</section>
			
			
	
		
		
	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
		<div id="ads300_100-widget-2" class="e3lan-widget-content e3lan300-100">
								<div class="e3lan-cell">
				<a href="https://content.yudu.com/web/69r/0A18qm2/CIEFeb2020/html/index.html?page=1"  >					<img src="https://cieonline.co.uk/wp-content/uploads/cie-digi-2.jpg" alt="" />
				</a>			</div>
								<div class="e3lan-cell">
				<a href="https://content.yudu.com/web/69r/0A18qm2/CIEDir2020/html/index.html?page=1"  >					<img src="https://www.cieonline.co.uk/wp-content/uploads/ciev2.png" alt="" />
				</a>			</div>
										</div>
			<div id="ads300_250-widget-4" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<ins data-revive-zoneid="714" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
			</div>
				</div>
			<div id="ads300_250-widget-3" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<ins data-revive-zoneid="441" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
			</div>
				</div>
				<div id="text-html-widget-3" class="text-html-box" >
			<div style="float:left; width:120px;">

<div>
<ins data-revive-zoneid="563" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>

<div>

<!-- Button -2 -->
<ins data-revive-zoneid="554" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>

<div>
<!-- Button -1 -->
<ins data-revive-zoneid="552" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>
<div>

<!-- Button 0 -->
<ins data-revive-zoneid="534" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>

<div>
<!-- Button 1 -->
<ins data-revive-zoneid="420" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>
<div>
<!-- Button 11 -->
<ins data-revive-zoneid="540" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>
<div>
<!-- Button 12 -->
<ins data-revive-zoneid="543" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>
<div>
<!-- Button 2 -->
<ins data-revive-zoneid="421" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>

<div>
<!-- Button 3 -->
<ins data-revive-zoneid="422" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>

<div>
<!-- Button 4 -->
<ins data-revive-zoneid="423" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>

<div>
<!-- Button 5 -->
<ins data-revive-zoneid="424" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<BR>
<br>
<!-- Button 15 -->
<div>
<ins data-revive-zoneid="674" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>

<div>
<!-- Button 6 -->
<ins data-revive-zoneid="471" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<div>
<!-- Button 7 -->
<ins data-revive-zoneid="475" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<div>
<!-- Button 8 -->
<ins data-revive-zoneid="477" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<div>
<!-- Button 9 -->
<ins data-revive-zoneid="524" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<br>
<div>
<ins data-revive-zoneid="539" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<!-- Button 13 -->
<div>
<ins data-revive-zoneid="671" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<!-- Button 14 -->
<div>
<ins data-revive-zoneid="672" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
<!-- Button 16 -->
<div>
<ins data-revive-zoneid="678" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
<script async src="//ads.datateam.co.uk/www/delivery/asyncjs.php"></script>
</div>
<br>
</div>

</div>
<div style="float:right; width:160px;">
<div>
<!-- Spot 1 -->
<ins data-revive-zoneid="425" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>


<div>

<!--Button -17 -->
<ins data-revive-zoneid="732" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>

<div>
<!-- Spot 2 -->
<ins data-revive-zoneid="426" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>
<BR>

<div>
<!-- Spot 3 -->
<ins data-revive-zoneid="529" data-revive-target="_blank" data-revive-id="9c421b7e485bf2edfee09708a4d06e2e"></ins>
</div>			</div>
		<div id="ai1ec_agenda_widget-2" class="widget widget_ai1ec_agenda_widget">

	<div class="widget-top"><h4>Upcoming Events</h4><div class="stripe-line"></div></div>
						<div class="widget-container">

<style>
<!--

-->
</style>
<div class="timely ai1ec-agenda-widget-view ai1ec-clearfix">

			<p class="ai1ec-no-results">
			There are no upcoming events.
		</p>
	 
			<div class="ai1ec-subscribe-buttons-widget">
							<a class="ai1ec-btn ai1ec-btn-default ai1ec-btn-xs ai1ec-pull-right
					ai1ec-calendar-link"
					href="https&#x3A;&#x2F;&#x2F;www.cieonline.co.uk&#x2F;calendar-2&#x2F;">
					View Calendar
					<i class="ai1ec-fa ai1ec-fa-arrow-right"></i>
				</a>
			
					</div>
	 
</div>



</div></div><!-- .widget /-->			<div id="text-html-widget-2" class="text-html-box" >
			<a class="twitter-timeline" data-width="300" data-height="600" href="https://twitter.com/CIE_Magazine">Tweets by CIE_Magazine</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>			</div>
			</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
					</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="https://www.cieonline.co.uk/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Twitter" href="https://www.twitter.com/cie_magazine" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

		
		<div class="alignleft">
			© Copyright 2020, Components in Electronics. <a href="http://www.datateam.co.uk/">Specialist Business Media Limited</a>. All rights reserved. <br>Registered in England No: 1771113. VAT No: 834 8567 90. <br>Registered Office: © Datateam Business Media, 15a London Road, Maidstone, Kent ME16 8LY. United Kingdom		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<style type="text/css" id="custom-background-css">body { background-position:top center !important;background-color: #e6e6e6 !important;background-image: url("https://www.cieonline.co.uk/wp-content/uploads/powersolver-bg-feb20-1.png") !important;background-repeat: no-repeat !important;background-attachment: fixed !important;}</style><div id="wps-bt-background-takeover-id" data-background-takeover-id="12"></div><script type='text/javascript'>
/* <![CDATA[ */
var spuvar = {"is_admin":"","disable_style":"","ajax_mode":"1","ajax_url":"https:\/\/www.cieonline.co.uk\/wp-admin\/admin-ajax.php","ajax_mode_url":"https:\/\/www.cieonline.co.uk\/?spu_action=spu_load","pid":"50398","is_front_page":"","is_category":"","site_url":"https:\/\/www.cieonline.co.uk","is_archive":"","is_search":"","is_preview":"","seconds_confirmation_close":"5"};
var spuvar_social = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/plugins/popups/public/assets/js/public.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/themes/sahifa/js/search.js'></script>
<script type='text/javascript' src='https://www.cieonline.co.uk/?ai1ec_render_js=common_frontend&#038;is_backend=false'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpsite_clickable_data = {"prefix_dash":"wps-bt-","ajaxurl":"https:\/\/www.cieonline.co.uk\/wp-admin\/admin-ajax.php","link_left":"https:\/\/powersolve.co.uk\/","link_right":"https:\/\/powersolve.co.uk\/","link_both":"","link_option":"0","link_url_left_target":"_blank","link_url_right_target":"_blank","dom_element":"body"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.cieonline.co.uk/wp-content/plugins/wpsite-background-takeover/js/wpsite_clickable.js'></script>

			<div id="cookie-notice" role="banner" class="cn-bottom wp-default" style="color: #fff; background-color: #000;"><div class="cookie-notice-container"><span id="cn-notice-text">This site uses cookies in order to function properly and to allow us to improve our service. You can learn more about our cookies, their use and how to disable them on our <a style="color:#FFFF00" href="https://cieonline.co.uk/cookies/">Cookie Page</a>. More information can also be found about our website within our <a style="color:#FFFF00" href="https://cieonline.co.uk/privacy-policy/">Privacy Policy</a> and <a style="color:#FFFF00" href="https://cieonline.co.uk/terms-conditions/">Terms &amp; Conditions</a>.
</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button wp-default button">Remove this message</a>
				</div>
				
			</div></body>
</html>